Commit 815fb528 authored by Mathieu Lirzin's avatar Mathieu Lirzin

Improved: Remove some explicit transitive dependencies

parent 2da6de10
......@@ -25,7 +25,6 @@ import org.asciidoctor.gradle.AsciidoctorTask
* ======================================================== */
plugins {
id 'application'
id 'java'
id 'groovy'
id 'eclipse'
id 'checkstyle'
......@@ -165,7 +164,6 @@ dependencies {
implementation 'com.sun.mail:javax.mail:1.6.2'
implementation 'com.sun.syndication:com.springsource.com.sun.syndication:0.9.0'
implementation 'com.thoughtworks.xstream:xstream:1.4.11.1'
implementation 'commons-cli:commons-cli:1.4'
implementation 'commons-fileupload:commons-fileupload:1.4'
implementation 'commons-net:commons-net:3.6'
implementation 'commons-validator:commons-validator:1.6'
......@@ -173,7 +171,6 @@ dependencies {
implementation 'net.fortuna.ical4j:ical4j:1.0-rc3-atlassian-11'
implementation 'org.apache.ant:ant-junit:1.10.7'
implementation 'org.apache.commons:commons-collections4:4.4'
implementation 'org.apache.commons:commons-csv:1.7'
implementation 'org.apache.commons:commons-dbcp2:2.7.0'
implementation 'org.apache.commons:commons-text:1.8'
implementation 'org.apache.geronimo.components:geronimo-transaction:3.1.4'
......@@ -183,7 +180,6 @@ dependencies {
implementation 'org.apache.poi:poi:4.1.0'
implementation 'org.apache.shiro:shiro-core:1.4.1'
implementation 'org.apache.sshd:sshd-core:1.7.0'
implementation 'org.apache.tika:tika-core:1.22'
implementation 'org.apache.tika:tika-parsers:1.22'
implementation 'org.apache.tomcat:tomcat-catalina-ha:9.0.29' // Remember to change the version number in javadoc.options block
implementation 'org.apache.tomcat:tomcat-jasper:9.0.29'
......@@ -198,12 +194,9 @@ dependencies {
implementation 'org.zapodot:jackson-databind-java-optional:2.6.1'
implementation 'oro:oro:2.0.8'
implementation 'wsdl4j:wsdl4j:1.6.3'
implementation 'org.jsoup:jsoup:1.12.1'
implementation 'com.auth0:java-jwt:3.8.3'
testImplementation 'org.hamcrest:hamcrest:2.1'
testImplementation 'org.hamcrest:hamcrest-library:2.1' // Enable junit4 to not depend on hamcrest-1.3
testImplementation 'org.mockito:mockito-core:3.1.0'
testImplementation 'com.pholser:junit-quickcheck-core:0.9'
testImplementation 'com.pholser:junit-quickcheck-generators:0.9'
runtimeOnly 'javax.xml.soap:javax.xml.soap-api:1.4.0'
runtimeOnly 'de.odysseus.juel:juel-spi:2.2.7'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment